
Notebook Help Index
The index lists all Help topics available for Notebook.    To learn how to use Help press F1 or 
choose Using Help from the Help menu.

Keyboard
Notebook Keys

Commands
File Menu
Edit Menu
Search Menu
Push Button Menu Items

Procedures
Backing Up a Text File
Copying, Cutting and Pasting Text
Creating New Documents
Deleting Text
Determining File Size
Finding Text
Formatting Text
Going To a Line
Merging a Text File
Opening an Existing Text File
Printing a Document
Replacing Text
Running an Application
Saving a Document
Selecting a Screen Font
Selecting Text
Setting Margins
Setting Tab Spacing
Showing Date and Time
Undoing Edits
Using the Bookmark
Wrapping Text



File Menu

The File menu includes commands that enable you to open and save files, establish a new 
workspace, and to print.

New Begins a new file.
Open Opens an existing file.
Save Saves the current document.
Save As Names the current document.
Backup Enables creation of a backup file.
Merge Inserts a text file anywhere in a document.
Run Starts an application and can open a document.
Margins Sets the margins to the printed document.
Print Prints the current document.
Exit Allows exit from Notebook.



Edit Menu

The Edit menu includes commands that enable you to move text to and from the clipboard, 
to undo a previous editing operation and to format the edit control.

Undo Cancels a previous operation.
Cut Deletes text and moves it to the clipboard.
Copy Copies text to the clipboard.
Paste Inserts text from the clipboard into the document.
Delete Deletes text without moving it to the clipboard.
Date Shows the date on the title bar.
Time Shows the time on the title bar.
Word Wrap Wraps text of a document.
Fonts Selects the screen font and the tab spacing.



Search Menu

The Search menu includes commands that enable you to go to a line, and/or to find the next 
or previous iteration of a text string, or to replace one or all occurrences of a text string.

Go To Allows line number, search and replace string entry.
Find Next Searches for the next occurrence of the search string.
Find Prev Searches for the previous occurrence of the search string.
Replace Replaces selected text with the replace string.
Replace All Replaces all occurrences of the search string with the replace string.
Bookmark Sets a bookmark position.
Position Displays the line number and document size information.



Push Button Menu Items

Push button menu items are the right aligned buttons on the menu bar.    A bitmap is used as
the command to scroll through a document from one field to the next.    The commands are 
enabled when scrolling is possible.    Notebook has a nominal field size of 32 thousand bytes. 
The overlap between fields is one line.

Field Scroll Down Scrolls to the next field.
Field Scroll Up Scrolls to the previous field.



File New Command

The New command clears the edit window and document name.

See...
Creating New Documents.



File Open Command

The Open command shows a dialog box to allow reading the selected file into memory for 
display and editing.

See...
Opening an Existing Text File.



File Save Command

The Save command writes the current named document to disk .

See...
Saving a Document.



File Save As Command

The Save As command shows a dialog box to allow naming or renaming the document which
then may be saved.

See...
Saving a Document.



File Backup Command

The Backup command allows the creation of a backup file when the document is saved the 
first time after the original file is opened.

See...
Backing Up a Text File.



File Merge Command

The Merge command allows the insertion of a text file into the document at the current caret
position.

See...
Merging a Text File.



File Run Command

The Run command allows the execution of an application and optionally the opening of an 
associated file.

See...
Running an Application.



File Margins Command

The Margins command allows sending title and page numbers and the setting of margins to 
the printed    document.

See...
Setting Margins.



File Print Command

The Print command sends the document to the print spooler.

See...
Printing a Document.



File Exit Command

The Exit command allows an exit from Notebook.    A message box is answered if changes 
were made.



Edit Undo Command

The Undo command allows the previous edit to be undone.

See...
Undoing Edits.



Edit Cut Command

The Cut command removes selected text sending the text to the clipboard.

See...
Copying, Cutting and Pasting.



Edit Copy Command

The Copy command sends selected text to the clipboard.

See...
Copying, Cutting and Pasting.



Edit Paste Command

The Paste command inserts clipboard text into the edit window.

See...
Copying, Cutting and Pasting.



Edit Delete Command

The Delete command removes selected text from the edit window.

See...
Deleting Text.



Edit Date Command

The Date command displays the month and date in a MM/DD format.

 See...
Showing Date and Time.



Edit Time Command

The Time command displays the hour and minute in an HH:MM format.

See...
Showing Date and Time.



Edit Word Wrap Command

The Word Wrap command allows the text of the edit contol to be wrapped.

See...
Wrapping Text.



Edit Fonts Command

The Fonts command shows a dialog box to allow selection of font and of tab-stop spacing.

See...
Selecting a Screen Font
Setting Tab Spacing.



Search GoTo Command

The Go To command shows a dialog box to enter a line number and/or search text.

See...
Finding Text
Going To a Line.



Search Find Next Command

The Find Next command continues a search for text in the forward direction.

See...
Finding Text.



Search Find Prev Command

The Find Prev command continues a search for text in the backward direction.

See...
Finding Text.



Search Replace Command

The Replace command replaces selected text with text from the replace edit control.

See...
Replacing Text.



Search Replace All Command

The Replace All command replaces all occurrences of the search string text with text from 
the replace edit control.

See...
Replacing Text.



Search Bookmark Command

The Bookmark command uses the caret position to set a document bookmark.

See...
Using the Bookmark.



Search Position Command

The Position command shows a modeless dialog box to display current line and document 
size.

See...
Determining File Size.



Field Scroll Down

The Field Scroll Down push button is inscribed with a down arrow.    The command will show 
the first page of the next field of the document in the edit window.

See...
Determining File Size
Formating Text.



Field Scroll Up

The Field Scroll Up push button is inscribed with an up arrow.    The command will show the 
first page of the previous field of the document in the edit window.

See...
Determining File Size
Formating Text.



Backing Up a Text File

1. Select unchecked Backup from the File menu.
2. A backup file is created when an opened file is saved for the first time.    The backup file 

will get the extension "bak".
3. Select the checked Backup from the File menu to disable backup file creation.
4. Notebook.ini holds the Backup status.



Copying, Cutting and Pasting Text

Copy, Cut and Paste selected from the Edit menu use the clipboard.

Copy
1. Select text from the edit window.
2. Select Copy from the Edit menu.

The selected text is copied to the clipboard.    The text remains selected.

Cut
1. Select text from the edit window.
2. Select Cut from the Edit menu.

The selected text is removed from the edit window and copied to the clipboard.

Paste
1. Text is copied to the clipboard.
2. Select Paste from the Edit menu.

The clipboard contents are inserted at the current caret position.



Creating New Documents

1. Select New from the File menu.
2. If there are changes to be saved then answer the message box.    The edit window is 

cleared, and the document will be "untitled".



Deleting Text

1. Select the text to be removed.
2. Select Delete from the Edit menu.

The selected text is removed from the edit window.



Determining File Size

1. Select unchecked Position from the Search menu.
2. The modeless dialog box is displayed to the left of the title bar and menu bar buttons.

The two values shown in the box are current line and document size.    The line value is 
the line number of the current caret position.    The size value is the number of bytes in 
the document.

3. Select the checked Position from the Search menu to remove the dialog box.
4. Notebook.ini holds the Position status.



Finding Text

1. Select Go To from the Search menu.
2. Enter the text to find in the search text control.
3. Check the Case check box to perform a case sensitive search.
4. Select the Next or Back push buttons depending on the search direction.
5. Use the Find Next or Find Prev    commands from the Search menu to continue a search.    

Or use the accelerator keys to continue a search.
6. Searches begin at the current caret position.    The entire document will be scanned to 

find matching text.    If no match is found the speaker is beeped.



Formating Text

1. To insert a space, press the Spacebar.
2. To end a line, press Enter.
3. To indent a line or insert a tab, press Tab.
4. To insert a blank line, move the caret to the beginning of a line, press Enter.
5. To split a line, move the caret to the text to move to the next line, press Enter.
6. To join two lines, move the caret to the beginning of the line to move.    Press Backspace 

until the lines are joined.

On File Open or File Merge, if the number of characters on a line is greater than 1024, 
then a message box will appear.    If an affirmative response is entered, then carriage 
return line feed pairs will be inserted into the document.    The position dialog box shows 
the number of insertions during the process.    This process may be aborted by pressing 
the escape key and answering the message box.
Line lengths must be equal to or less than 1024 characters when scrolling from one field 
to the next.



Going To a Line

1. Select Go To from the Search menu to show the dialog box.
2. Enter the number of the line to go to in the line number control.
3. Select the Next or Back push buttons or press Enter.
4. Going To a Line can be combined with Finding Text.    If the line number entry is greater 

than the actual number of lines in the document, the speaker is beeped.
5. The End push button will show the last line of the document in the edit window.



Merging a Text File

1. Move the caret to the position in the document where the file is to be placed.
2. Select Merge from the File menu to show the dialog box.
3. The default check box can quickly set the open filespec to *.TXT or *.* for the list box.
4. Select a file from the list box.    Or type the appropriate text into the edit control.
5. Select Merge.

See...
Formating Text.



Opening an Existing Text File

1. Select Open from the File menu to show the dialog box.
2. The default check box can quickly set the open filespec to *.TXT or *.* for the list box.
3. Select a file from the list box.    Or type the appropriate text into the edit control.
4. Select Open.

The filename of a text file as a command line parameter will open the file after Notebook 
initialization.    Appropriate modification to the Extensions section of the win.ini file allows
associated opening.

See...
Formating Text
Running an Application.



Printing Documents

1. Select Print from the File menu.
2. The current document is sent to the print spooler.    Printing may be aborted while the 

print file is being created.    Lines that do not fit inside the margins will be wrapped.

See...
Notebook Keys
Setting Margins.



Replacing Text

To replace a single instance of selected text...
1. Select GoTo from the Search menu to show the dialog box.
2. Enter text into the replace edit control.
3. Select text of the document with the keyboard or mouse.
4. Select Replace from the Search menu or use the accelerator keys.

The replace command with the finding text features can selectively replace repeating 
words or small phrases.

To replace all occurrences of the search string with the replace string...
1. Select GoTo from the Search menu to show the dialog box.
2. Enter text into the search and into the replace edit controls.
3. Select Next or Back to find an instance of the search string.
4. Select Replace All from the Search menu or use the accelerator key.

The replace all command shows a message box with the occurrence count and the string 
values.    If the message box receives an affirmative response, then the process of 
replacing all occurrences begins.    The position dialog box shows the number of 
occurrences left during the process.    The replace process may be aborted by pressing 
the escape key and answering the message box.    Upon completion the edit window 
shows the first line of the document.

See...
Notebook Keys.



Running an Application

1. Select Run from the File menu to show the dialog box.
2. The default check box can quickly set the run filespec to *.* or *.EXE for the list box.
3. Select an application or associated file with the mouse by using the list boxes.    Or type 

the exact or appropriate text into the command line edit control.    If the application 
filename does not contain an extension, then .EXE is assumed.

4. Select Run or press the enter key.
This feature allows an efficient system interface and fast utilization of Notebook output 
with other applications.

See...
Opening an Existing Text File.



Saving Documents

To save an untitled document or rename the document...
1. Select Save As from the File menu to show the dialog box.
2. Enter a filename into the edit control.
3. Select Save.

To save a titled document ...
1. Note only documents that have been changed can be saved.
2. Select Save from the File menu.



Selecting a Screen Font

1. Select Fonts from the Edit menu to show the dialog box.
2. Select a font from the radio-button control choices.
3. Select Accept.
4. Notebook.ini holds the screen Font status.

See...
Setting Tab Spacing.



Selecting Text

1. Move the caret with the mouse pointer to the beginning or end of the text to select.
2. Hold down the mouse button while moving the pointer to highlight the text.
3. Release the mouse button when the correct amount of text is highlighted.

See...
Notebook Keys.



Setting Margins

1. Select Margins from the File menu to show the dialog box.
2. The check box control for the margin must be checked to allow the change.
3. Select a margin size from the list box control.
4. The header can be customized by typing into the title edit control.    The default header is

the document filename.
5. To allow the header or the page number as a footer to be sent to the print spooler, check 

the appropriate check box.
6. Choose Accept.
7. Notebook.ini holds the margin size.



Setting Tab Spacing

1. Select Fonts from the Edit menu to show the dialog box.
2. Select a tab-stop spacing from the list box control choices.
3. Select Accept.

The tab-stop spacing is also used to format the document sent to the print spooler for 
hardcopy.    Notebook.ini holds the tab spacing value.

See...
Selecting a Screen Font.



Showing Date and Time

1. Select Date or Time from the Edit menu to display the date or time, respectively .
2. The MM/DD or HH:MM format is shown in the title bar.    Accelerator keys can toggle the 

date and time display as desired.
3. Notebook.ini holds the date and time status.

See...
Notebook Keys.



Undoing Edits

1. Verify that Undo from the Edit menu is enabled.
2. If enabled, then select Undo from the Edit menu to undo the last edit.



Using the Bookmark

1. Select Bookmark from the Search menu to set the bookmark.    Bookmark command will 
be checked when set.    Caret position is the offset stored as a bookmark.

2. If Bookmark is set when selected, then a message box is shown to allow the user to clear
the bookmark.    A new bookmark can be set after the old one is cleared.

3. Select Go To from the Search menu to show the dialog box.
4. Select the Bookmark push button control.
5. The edit control will show the offset into the document that was stored when the 

bookmark was set.    The bookmark is a number only.    It is not associated with any 
particular document.    If the bookmark is not set, then selecting the Bookmark push 
button will show the beginning of the document which is zero offset.    Notebook.ini holds 
the Bookmark status.



Wrapping Text

1. Choose Word Wrap from the Edit menu.
2. The edit control is redrawn with no horizontal scroll bar to indicate word wrap mode.
3. Text will be broken at a space character.
4. Notebook.ini holds word wrap status.

A word wrapped edit control needs twice as much local buffer memory when Notebook is 
minimized.    Therefore field size is nominally 16 thousand bytes in word wrap mode.





Notebook Keys

Choose from the following list to review the keys used in Notebook.

Cursor Movement Keys
Dialog Box Keys
Editing Keys
Function Keys
Menu Keys
System Keys
Text Selection Keys
Window Keys



Cursor Movement Keys
The mouse pointer is called the cursor.    The text insertion point is called the caret.

Key(s) Function

DIRECTION key Moves the caret left, right, up, or down in a field.
CTRL+Home Moves to the beginning of a field.
CTRL+End Moves to the end of a field.
Home Moves to the beginning of a line.
End Moves to the end of a line.
CTRL+Left Arrow Moves left one word.
CTRL+Right Arrow Moves right one word.
PAGE UP or PAGE DOWN Moves up or down in a field, one screen at a time.

See...
Formatting Text.



Dialog Box Keys

Key(s) Function

TAB Moves from field to field (left to right and top to bottom).
SHIFT+TAB Moves from field to field in reverse order.
ALT+letter Moves to the option or group whose underlined letter matches 

the one you type.
DIRECTION key Moves from option to option within a group of options.
ENTER Executes a command button.

Or, chooses the selected item in a list box and executes the 
command.

ESC Closes a dialog box without completing the command. (Same as
Cancel)

ALT+DOWN ARROW Opens a drop-down list box.
ALT+UP or DOWN ARROW Selects item in a drop-down list box.
SPACEBAR Cancels a selection in a list box.

Selects or clears a check box.
CTRL+SLASH Selects all the items in a list box.
CTRL+BACKSLASH Cancels all selections except the current selection.
SHIFT+ DIRECTION key Extends selection in a text box.
SHIFT+ HOME Extends selection to first character in a text box.
SHIFT+ END Extends selection to last character in a text box



Editing Keys

Key(s) Function

Backspace Delete the character to the left of the caret.    Or, delete 
selected text.

ALT+Backspace Undo the previous edit.
SHIFT+Delete Cut selected text from the edit window and move it to the 

clipboard.
CTRL+Insert Copy selected text from the edit window and move it to the 

clipboard.
SHIFT+Insert Paste text from the clipboard to the caret position.
ALT+Insert Replace selected text with text from the dialog box replace edit 

control by way of the clipboard.
Delete Delete the character to the right of the caret.    Or, delete 

selected text.

See...
Copying, Cutting and Pasting Text
Deleting Text
Selecting Text.



Function Keys

Key(s) Function

F1 Gets Help and displays the Help Index for Notebook. If the Help 
window is already open, pressing F1 displays the "Using 
Windows Help" topics.

F2 If there is text in the edit window, then the text is sent to the 
print spooler.

F3 If search text has been entered into the Go To dialog box, a 
search for the next occurrence of the string is performed.

F4 If search text has been entered into the Go To dialog box, a 
search for the previous occurrence of the string is performed.

F5 The real time clock date is displayed on or removed from the 
title bar.

F6 The real time clock time is displayed on or removed from the 
title bar.

F7 If search and replace text have been entered into the Go To 
dialog box, the replacement of all occurrences of the search 
string with the replace string is performed.

See...
Finding Text
Printing Documents
Replacing Text
Showing Date and Time.



Menu Keys

Key(s) Function

Alt Selects the first menu on the menu bar.
Letter key Chooses the menu, or menu item, whose underlined letter 

matches the one you type.
Alt+letter key Pulls down the menu whose underlined letter matches the one 

you type.
LEFT or RIGHT ARROW Moves among menus.
UP or DOWN ARROW Moves among menu items.
Enter Chooses the selected menu item.



System Keys

The following keys can be used from any window.
Key(s) Function

Ctrl+Esc Switches to the Task List.
Alt+Esc Switches to the next application window or minimized icon, 

including full-screen programs.
Alt+TAB Switches to the next application window, restoring applications 

that are running as icons.
Alt+PrtSc Copies the entire screen to Clipboard.
Ctrl+F4 Closes the active window.
F1 Notebook uses the help engine.    See Hot Keys.



Text Selection Keys

Key(s) Function

SHIFT+LEFT or RIGHT ARROW Selects text one character at a time to the left 
or right.

SHIFT+DOWN or UP Selects one line of text up or down.
SHIFT+END Selects text to the end of the line.
SHIFT+HOME Selects text to the beginning of the line.
SHIFT+PAGE DOWN Selects text down one window.

Or, cancels the selection if the next window is 
already selected.

SHIFT+PAGE UP Selects text up one window.
Or, cancels the selection if the previous 
window is already selected.

CTRL+SHIFT+LEFT or RIGHT ARROW Selects text to the next or previous word.
CTRL+SHIFT+UP or DOWN ARROW Selects text to the beginning (UP ARROW) or 

end (DOWN ARROW) of the paragraph.
CTRL+SHIFT+END Selects text to the end of the field.
CTRL+SHIFT+HOME Selects text to the beginning of the field.

See...
Selecting Text.



Window Keys

Key(s) Function

ALT+SPACEBAR Opens the Control menu for an application window.
ALT+Hyphen Opens the Control menu for a document window.
Alt+F4 Closes a window.
Alt+Esc Switches to the next application window or minimized icon, 

including full-screen programs.
Alt+TAB Switches to the next application window, restoring applications 

that are running as icons.
Alt+ENTER Switches a non-Windows application between running in a 

window and running full screen.
DIRECTION key Moves a window when you have chosen Move from the Control 

menu.
Or, changes the size of a window when you have chosen Size 
from the Control menu.





Accelerator Keys

Accelerator keys are shortcut keys that let the user choose a command from a menu by 
using a single key stroke.



Associate

To identify a filename extension as belonging to a particular application, so that the 
requested opening of any file with that extension will immediately run the particular 
application and open the requested file.



Bitmap

A bitmap is an image formed by a pattern of bits.



Caret

The caret is the text insertion point of an edit control.    It is represented by a blinking vertical
bar.



Clipboard

The clipboard is the main data-exchange feature of Windows.    It is a common area to store 
data handles by which applications can exchange formatted data.



Control

A control is a predefined child window that carries out a specific input or output.



Cursor

The cursor is a special bitmap that shows the user where actions initiated with the mouse 
will take place.    The cursor can be an arrow, hourglass, I-beam, cross-hair or other custom 
shape.



Field

A field is a memory resouce with application determined content and size.




